New 2B.. Is this working right?

General Chit Chat about E-Stim. Not just E-Stim Systems, but ErosTek, PES and others.
Post Reply
Mikel737
Active
Posts: 4
Joined: Sun Mar 22, 2020 2:38 am
Location: Usa

New 2B.. Is this working right?

Post by Mikel737 » Sun Mar 22, 2020 2:54 am

Hello all! Brand new user to the 2B however not new to stimming. Currently I have an ElectraStim Axis that I enjoy but i just bought and received a new 2B hoping it was an upgrade. To me it seems like I got a defective unit unless this is the way they’re supposed to operate. Here’s my issues..
first I got the 2b without the power adaptor and noticed when using it the screen would kinda fade in and out quickly with some juice applied. Also noticed that the levels were kinda strange. Turning a up would lower b or vise versa. So figuring it was a battery issue I ordered and received the power adaptor. Still having the same issue and the screen really goes nuts when you plug in audio for stimming. The screen is barely usable and the a and b power knobs don’t even respond to input. If they do it takes many turns to do aNything.
Also I noticed that the wave programs are ok but anything with a pulse I have to turn the power up to at least 35-40 before I feel anything. With waves I’ll feel them around 10. Obviously there’s a HUGE difference which is downright scary!
And the last thing is the feel knob. That doesn’t seem like it does much at all. Barely barely noticeable.

Any suggestions on what the deal could be or is this normal? I find it hard to believe. Should I try a reset? I didn’t get the upgrade cable as that was another bunch of money I didn’t expect to need just yet.

Kinda disappointed but not giving up.

Thanks!!!
Mike



User avatar
admin
Site Admin
Posts: 1138
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: New 2B.. Is this working right?

Post by admin » Sun Mar 22, 2020 10:08 pm

Mikel737 wrote:
Sun Mar 22, 2020 2:54 am
Hello all! Brand new user to the 2B however not new to stimming. Currently I have an ElectraStim Axis that I enjoy but i just bought and received a new 2B hoping it was an upgrade. To me it seems like I got a defective unit unless this is the way they’re supposed to operate. Here’s my issues..
first I got the 2b without the power adaptor and noticed when using it the screen would kinda fade in and out quickly with some juice applied.
What exactly do you mean the screen fades in and out? does it get bright and dim?
Also noticed that the levels were kinda strange. Turning a up would lower b or vise versa. So figuring it was a battery issue I ordered and received the power adaptor. Still having the same issue
How are you connecting the outputs? the channels are physically independent. Yes if you load once channel more than the other especially on battery you might see a difference, but generally its more related to where you have placed pads, or loops or other electrodes.
and the screen really goes nuts when you plug in audio for stimming. The screen is barely usable and the a and b power knobs don’t even respond to input. If they do it takes many turns to do aNything.
Because of the level of processing power needed for audio, the control in stereo modes are a little less responsive than other modes. The display will flicker depedning on what the input is doing, if the display is blanking then you are overdriving the inputs.
Also I noticed that the wave programs are ok but anything with a pulse I have to turn the power up to at least 35-40 before I feel anything. With waves I’ll feel them around 10. Obviously there’s a HUGE difference which is downright scary!
People are different. which is why some modes feel at different levels to others. Its not scary, it's called work with how it feels, not just a number.
And the last thing is the feel knob. That doesn’t seem like it does much at all. Barely barely noticeable.
There are two feel controls, which vary in use depending on the mode. Again feel is very subjective and depends on the mode.
Any suggestions on what the deal could be or is this normal? I find it hard to believe. Should I try a reset? I didn’t get the upgrade cable as that was another bunch of money I didn’t expect to need just yet.
Yup try a factory reset. You could also drop the customer services team an email to see if they could help.
Kinda disappointed but not giving up.
Good!!

Si
E-Stim Systems Ltd

Mikel737
Active
Posts: 4
Joined: Sun Mar 22, 2020 2:38 am
Location: Usa

Re: New 2B.. Is this working right?

Post by Mikel737 » Mon Mar 23, 2020 1:36 am

Hey thanks for the reply!

Put a little time into this forum and found many answers to questions I had after I posted. I def should of researched before posting.. I apologize!!

First I was def overloading the stereo input and that was affecting the screen. After lowering the output from the computer stim file to a normal level everything was perfect and felt great!

There’s def a learning curve to every power box and I can tell with a little time this will be one of my favorites I’ve had! Also noticed that the 2B leaves you less numb the next day unlike some other boxes I’ve had/have.

Thanks again for the reply and I hope this helps newbies to stim and the 2b to realize there’s a lot more to it than just plugging in a going for it.

Thanks!!
Mike

User avatar
Stimaddict
Active Developer
Posts: 353
Joined: Wed Oct 25, 2017 11:56 am
Location: UK

Re: New 2B.. Is this working right?

Post by Stimaddict » Mon Mar 23, 2020 5:15 pm

Mikel737 wrote:
Mon Mar 23, 2020 1:36 am
fter lowering the output from the computer stim file to a normal level everything was perfect and felt great!

There’s def a learning curve to every power box and I can tell with a little time this will be one of my favorites I’ve had!
Hi Mike - Don't worry, we all make mistakes. Give your new 2B a chance and it will run circles around your ElectraStim Axis. Used properly your 2B will have you begging for mercy and cummin' back for more :D -- May I suggest reading these posts?

** Advice for *NEW* 2B owners - viewtopic.php?f=14&t=9716&p=14259

** 2B - Tips for 'smoothness': viewtopic.php?f=14&t=9602

**For advice on using audio files in Stereo Mode: viewtopic.php?f=14&t=9670&p=14169#p14169

=============================================================================================
Anyone is welcome to PM me for a download link to hundreds of free, shared mp3 stimfiles organized by author - some up to 4 hours long!
I cannot post the link here out of respect for this forum's Admin and the complicated copyright issues it could involve them in.

Mikel737
Active
Posts: 4
Joined: Sun Mar 22, 2020 2:38 am
Location: Usa

Re: New 2B.. Is this working right?

Post by Mikel737 » Tue Mar 24, 2020 1:19 am

Thank you very much for pointing out those topics! I’ll def read em!!

And I’ll be PM’ing you for a stim file download link!! Found a few nice ones last night. Great device!!

Mike

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest