2B box not connecting to E-stim Connect

User support for our new E-Stim Connect service. Looking for help? Then have a look at https://e-stim.online for instructions and answers to frequently asked questions. Comments and suggests for improvement of the service are always welcome.
poppguy
Newbie
Posts: 2
Joined: Thu Nov 22, 2018 4:24 am
Location: SF

2B box not connecting to E-stim Connect

Post by poppguy » Thu Nov 22, 2018 4:34 am

Hi!

I just got my 2B and I am very excited. The whole point of me choosing this system is the remote interface.
Unfortunately I spent 2h trying to get the E-stim Connect to work without success.

I am running Windows 7. I started by installing the driver from the USB I got in the bonus pack.
When going to Windows Device Manager / Ports (COM&LPT) I see an incon USB Serial Port COM5. All good.

I then plug the USB-like cable from the bonus pack in one of my PC USB port, the jack at the other end in the middle port of the 2B. Turn the 2B on, select my way to commander mode, turn it On (I still get A:OFF and B:OFF displayed).
Nothing happens automatically on the computer.

I start E-stim connect, select COM5, click connect. After 10 sec I get "No response from the 2B. Please check the connection then click Retry, or click Cancel to disconnect"

I am stuck here.

Is there something I am doing wrong? I tried from a second computer (also windows 7) and reached the same problem.

Any help would be MUCH appreciated. I would be most disappointed if my investment in the box did not allow remote play :-(

Poppguy



User avatar
admin
Site Admin
Posts: 1052
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: 2B box not connecting to E-stim Connect

Post by admin » Thu Nov 22, 2018 10:32 am

I then plug the USB-like cable from the bonus pack in one of my PC USB port, the jack at the other end in the middle port of the 2B. Turn the 2B on, select my way to commander mode, turn it On (I still get A:OFF and B:OFF displayed).
Nothing happens automatically on the computer.
This comes under read the manual...... once you see 'Commander: On A:OFF and B:OFF' displayed, press select to enable it and return to the normal display. You have not yet activated Commander on your 2B.

Si
E-Stim Systems Ltd

poppguy
Newbie
Posts: 2
Joined: Thu Nov 22, 2018 4:24 am
Location: SF

Re: 2B box not connecting to E-stim Connect

Post by poppguy » Fri Nov 23, 2018 8:00 pm

OK figured it out.

As mentionned I did turned to commander mode ON.

What I did not realize is you actually have to EXIT the commander menu once it is ON for the box to be recognized by the software.
Now I am having so much fun, thank you!!

Mattin
Active
Posts: 9
Joined: Fri Jan 25, 2019 4:53 pm
Location: Arre (Nafarroa) SPAIN
Contact:

Re: 2B box not connecting to E-stim Connect

Post by Mattin » Thu Feb 07, 2019 11:56 am

I have the same problem... more or less. But I can't "select my way to Commander mode" as you say. Where's taht?
Same matter with Connect: all downloaded, in theory all perfect but anyway working. I have contacted with a developer from Madrid that is here too and has told me that may be someproblem with the pc/laptop ports... though drivers were downloaded correctly. Never ending problem here.

User avatar
admin
Site Admin
Posts: 1052
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: 2B box not connecting to E-stim Connect

Post by admin » Thu Feb 07, 2019 12:27 pm

If you are running 2.105... double press the select button to change mode, select '22 Commander' press select, Adjust the display to show 'Commander:On' and then press select to go back to the main screen. You will now see an arrow on the bottom line of the screen indicating Commander is on.

Have a look at https://e-stim.info/instructions/select-commander

Does your PC/Mac see the Com port when the digital link is plugged in? does it vanish when the USB connection is removed?

Si
E-Stim Systems Ltd

Mattin
Active
Posts: 9
Joined: Fri Jan 25, 2019 4:53 pm
Location: Arre (Nafarroa) SPAIN
Contact:

Re: 2B box not connecting to E-stim Connect

Post by Mattin » Fri Feb 08, 2019 11:39 am

No, I have 2.106 and have not this function or programm.

User avatar
LondonSubNigel
Active Developer
Posts: 261
Joined: Wed Jul 06, 2011 5:13 pm
Location: London
Contact:

Re: 2B box not connecting to E-stim Connect

Post by LondonSubNigel » Fri Feb 08, 2019 1:43 pm

Which version of Windows are you running? There are different driver packages for different versions, so make sure you have the correct one. In Device Manager (or whatever it's called) can you see the serial ports listed? Are they shown as working correctly?

If there is an error message from the Connect app, exactly what is it?

User avatar
admin
Site Admin
Posts: 1052
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: 2B box not connecting to E-stim Connect

Post by admin » Fri Feb 08, 2019 1:49 pm

I'm confused you say you have 2.106, as we don't supply 2.106 on production 2B's so if you have 2.106 then it must have been successfully downloaded. What version is the 2B actually running???


how to install drivers https://e-stim.online/installation/drivers-pc

How to install Connect https://e-stim.online/installation/pc-install

How to Switch Commander on on a 2B https://e-stim.online/using/2b-commander-mode

Si
E-Stim Systems Ltd

Mattin
Active
Posts: 9
Joined: Fri Jan 25, 2019 4:53 pm
Location: Arre (Nafarroa) SPAIN
Contact:

Re: 2B box not connecting to E-stim Connect

Post by Mattin » Fri Feb 08, 2019 2:06 pm

Thank you for your attention. Yes, I have 2.106 because iI bought the accesory pack last week or so. All items were discharged (drivers, Uplink, Connect and Commander...) and ports works correctly. I have done all those operations at least twice in each computer. The computer that I will use is the new one, a laptop with Windows 10 bought a year ago, more or less.
I will speak with neo80 when he is free and maybe he will take my lapto's control to do all correctly, but, real- really, I have done all some times.

Thank you again

User avatar
admin
Site Admin
Posts: 1052
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: 2B box not connecting to E-stim Connect

Post by admin » Fri Feb 08, 2019 2:08 pm

again. what version is on your 2B. 2.106 is NOT included in the accessory pack, and we do NOT install 2.106 on any unit - it is classed as a Beta. If someone has updated the unit for you, then I suggest you talk to them, as clearly the 2B and the digital link are working.

If you have 2.105 then you need to follow all the instructions step by step

For instance have you checked if the drivers have been correctly installed?

https://e-stim.online/faqs/how-do-i-che ... d-on-my-pc


Si
E-Stim Systems Ltd

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest