Fire button intermittent/loose connection?

The powerbox that started it all. No longer manufactured and replaced by the new ElectroHelix, but still a popular unit.
Post Reply
trillium
Newbie
Posts: 2
Joined: Thu Aug 14, 2014 6:54 pm

Fire button intermittent/loose connection?

Post by trillium » Fri Aug 15, 2014 4:55 pm

Hellos,

I've just receive my S1 box (4her set) today, I've tested and all seems to work other then the fire button. It does activate but even fully pressed the activity light sporadically goes off and back on, mainly when the box is moved/tapped but also does it anyway when the button is less then 98% pushed in.

I think the button is the same as on the pictured units, just in red in place of black, the hole is about x1.5 of that of the button and the button is not centered but pressed against the top of the hole?
I took a pic earlier for my Fet profile, I think it shows what I mean about the button placement.

I'm guessing this is a fault and I have to send it back? I don't really want to have to after just getting it as was looking forward to having a play.

Thanks
Lily


Image



User avatar
admin
Site Admin
Posts: 995
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: Fire button intermittent/loose connection?

Post by admin » Sat Aug 16, 2014 8:01 pm

Love the pink!!!!

The fire button is normally slightly recessed into the box in order to prevent it being pressed inadvertently, but if you are finding it a problem with contact HQ and we can arrange a replacement.

Si
E-Stim Systems Ltd

trillium
Newbie
Posts: 2
Joined: Thu Aug 14, 2014 6:54 pm

Re: Fire button intermittent/loose connection?

Post by trillium » Sat Aug 16, 2014 8:55 pm

My mistake must have not been pressing the button fully as seems to work fine once I had it attached up to myself :) and actually it's nice in that it's easy to do very quick short taps the button.

Though I've another issue, seemly determined to find fault with your long established device... is it possible the pulse feel knob could be wired up back to front? soft is giving me more spiky electro shock sort of feel and hard is giving a more throbbing but without much tingle feel... (I had it rigged with two of your sticky pads, one on each inner thigh)...

And also a question, how can I make the shocks less bearable/feel harsher? would using smaller pads work? (I've yet to try the insert, I'm waiting on a delivery for some conductive gel, which I wish I got a tube from you now as I'm impatient but it was hard not to go for 4 tubes of the same 360 type for the same price with P&P, can PM you the place if of interest)

Lily x

trussedworthy
Newbie
Posts: 2
Joined: Fri Dec 18, 2015 8:11 am

Re: Fire button intermittent/loose connection?

Post by trussedworthy » Fri Dec 18, 2015 8:22 am

I had the same problems with my series 1 box.

User avatar
MickEstim
Staff
Posts: 34
Joined: Fri May 15, 2015 6:12 pm

Re: Fire button intermittent/loose connection?

Post by MickEstim » Fri Dec 18, 2015 9:16 pm

Smaller pads would certainly give a harsher feel as the smaller point of contact the more intense the sensation.

Not sure I would be using 360 internally as it is designed as a surface gel for ultrasound and it doesn't say it is safe for internal use, but then again it doesn't say it isn't safe. I would just rather use a lube/gel designed for internal use personally.
Mick
Sales Director
E-Stim Systems

Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest