e-Stim Connect4 lag/stalling

The most versatile and user friendly E-Stim control unit available today. If you want More Power, More Control, and more fun, then the 2B is the one you want.
Post Reply
digiboi
Newbie
Posts: 3
Joined: Sun Mar 12, 2023 7:12 pm
Location: UK

e-Stim Connect4 lag/stalling

Post by digiboi »

Hi,

I had the same issue with Connect previously, and today upgraded my firmware to try Connect 4.

Basically, the connection works but after the user does a few clicks (to increase/decrease levels, for example) or maybe a minute or so, the page just stops functioning. The only button that works then is the disconnect button (but that doesn't stop the box from still running), clicking on stop doesn't work either.

I'm not sure if this is because my laptop is old, or is this just a luck of draw, some days the connection are better than others?

Just wondering if anyone else is facing the same issues - I tried using keywords to search in the forum to see if this has been discussed before but can't find anything. Apologies if this has been discussed.


User avatar
admin
Site Admin
Posts: 2134
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: e-Stim Connect4 lag/stalling

Post by admin »

Connect works as a loop between the 2B, your laptop the server and the webpage. so you click on the webpage, which is processed by the server, sent to your laptop, then the 2B, which then responses and that is then passed to your laptop and then the server then displayed on the web screen. The issue is the internet is stateless, so depending on how you are connected and via what you can get delays.

you might get some more details from the debugging that appears at the bottom of the web screen when commands are sent.

what version of Connect/Firmware are you running?

Si
E-Stim Systems Ltd
digiboi
Newbie
Posts: 3
Joined: Sun Mar 12, 2023 7:12 pm
Location: UK

Re: e-Stim Connect4 lag/stalling

Post by digiboi »

I’ll try it out again later and look for the debugging at bottom of screen.

I updated yesterday to the latest public beta (2.122? I think) and using Connect4.

I had similar issues with the older firmware and Connect3 so hoped that this update would solve it.

But understand about the loop - was just wondering if this was an issue on my end!
User avatar
admin
Site Admin
Posts: 2134
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: e-Stim Connect4 lag/stalling

Post by admin »

the latest is 2.126

if you have had similar issues with previous FM then I would suggest looking at things like anti virus/VPNs firewalls etc as well as your broadband, generally the link is pretty fast and isnt dependent on the firmware or 2B hardware.

Si
E-Stim Systems Ltd
digiboi
Newbie
Posts: 3
Joined: Sun Mar 12, 2023 7:12 pm
Location: UK

Re: e-Stim Connect4 lag/stalling

Post by digiboi »

Thanks for this, Si. I’ll look into it!
Post Reply