Plunging pete not working with Zeus powerbox

General Chit Chat about E-Stim. Not just E-Stim Systems, but ErosTek, PES and others.
Post Reply
superdeeduper42069
Newbie
Posts: 3
Joined: Sun Jan 05, 2020 4:47 pm
Location: South Carolina

Plunging pete not working with Zeus powerbox

Post by superdeeduper42069 » Sun Jan 05, 2020 4:50 pm

The cable that the pete came with doesn't fit the powerbox so I tried using one of the cables that fit my powerbox but that didn't work either. Is there an adapter that would work with this or do I have to buy a whole Mystim unit? Here are some pictures: https://imgur.com/a/iyIjd0v
1. Powerbox
2. Plunging pete cable
3. Powerbox cable
4. Cables compared



User avatar
admin
Site Admin
Posts: 1091
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: Plunging pete not working with Zeus powerbox

Post by admin » Sun Jan 05, 2020 6:59 pm

Honestly? Since this is an E-Stim Systems forum I would say throw the zeus unit away and buy an ElectroPebble https://www.e-stimsystems.com/electropebble or ElectroHelix https://www.e-stimsystems.com/index.php ... cts_id=122 (both are still in the January sale if you hurry), but without seeing the connections on the Zeus box it is difficult to suggest a cable. Zeus are know for using weird cables as they are normally weird rebadged Chinese units. We do adaptors and cables that will fit the Plunging Pete, but only for our units and a few other made for play devices.

Si
E-Stim Systems Ltd

superdeeduper42069
Newbie
Posts: 3
Joined: Sun Jan 05, 2020 4:47 pm
Location: South Carolina

Re: Plunging pete not working with Zeus powerbox

Post by superdeeduper42069 » Mon Jan 06, 2020 2:29 am

I appreciate the thought but I wanted to try and avoid spending too much money on a new box. In my imgur link I took pictures of all the cables and leads. I'm just confused as to why there's nothing happening at all. There's absolutely no electricity flowing through it at all which seems weird considering the cables that came with the powerbox fit and work with other things.

User avatar
admin
Site Admin
Posts: 1091
Joined: Tue Feb 19, 2008 8:14 pm
Location: Watford,UK
Contact:

Re: Plunging pete not working with Zeus powerbox

Post by admin » Mon Jan 06, 2020 11:55 am

are you plugging them into the correct position?
pp.jpg
you need one plug in the lower end, one in the upper, NOT both in the lower end

Si
You do not have the required permissions to view the files attached to this post.
E-Stim Systems Ltd

superdeeduper42069
Newbie
Posts: 3
Joined: Sun Jan 05, 2020 4:47 pm
Location: South Carolina

Re: Plunging pete not working with Zeus powerbox

Post by superdeeduper42069 » Tue Jan 07, 2020 12:27 am

...In my defense it came plugged into the two lower straps.

Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests